Balance Updates Not Functional

Incident Report for t1

Resolved

All third party dependencies have resolved, and our systems are working normally
Posted Nov 19, 2025 - 13:27 UTC

Monitoring

Due to a CloudFlare outage with basescan, arbiscan, and some RPCs, some of our software is currently unable to fetch balances and they may report incorrectly as zero in the UI.
Posted Nov 18, 2025 - 13:51 UTC
This incident affected: Cloudflare API.